Author Topic: New Patch [1.28.2] - Check for common issues  (Read 2398 times)

Offline luke

  • ~evil~
  • Honored member
  • MonsterKill Member
  • *
  • Topic Author
  • Posts: 3430
  • Country: de
  • Karma: +449/-212
  • Awards Lagabuse Legend Hacks staff member [RARE] Shadow Raze Tour Award [RARE] Best B&U mod of the month 3 times in a row [EPIC] 3rd Place Admins Cup [EPIC] Uther Party Tournament Winner [COMMON]
    • View Profile
    • Awards
The server was updated to 1.28.2 recently, there are some problems for now but they are beeing fixed. Please check this link for details and the intsructions of how to update your game.

Note that its always better to install version switcher and gproxy in their own directories and not in your main warcraft 3 directory.

http://eurobattle.net/threads/206071-Server-updated-to-W3-1-28-2-READ

Common issues:

1) Unable to connect through Gproxy gateway -> reinstall Gproxy v8 from the link above

2) Icons are displayed as green squares -> fixed

3) Unable to alttab properly -> tick "Native Fullscreen" in eurobattle.net Client

4) Messed up ingame resolution -> read the post below

5) Game works only in windowed mode and renders a black screen otherwise -> try to set a different resolution (in video settings after launching it in windowed mode) and then change the game to full screen or tick "Native Fullscreen"

6) Seems that gproxy doesn't launch warcraft 3 by clicking on the gproxy gateway (on the main gproxy window) and displays a messenge that it is already running sometimes -> Just restart it and it should work fine

7) "not enough storage is available to process this command" once the game starts file migration after launching it for the first time after patching -> Move your maps and replays to a separate folder and start the migration again.

8.) "Files are opened/used by another process" during migration -> Move Maps, Replays, Campaigns, AI Scripts, Erros, Logs, ScreenShots, Scripts folders from the main directory to Documents/Warcraft III manually and start the migration again

9) Dark colors -> http://eurobattle.net/threads/206090-Gamma-brigtness-fix-and-alttab-fix

10) Some custom games are missing -> wait until the other bot owners reconfigure their bots for the current patch

11) File Migration restarts on each launch and fails -> Try to clean up your warcraft 3 folder from unnecessary files, uninstall gproxy and install it again in another directory

12) "war3.exe not started from known InstallPath/w3dir registry entry" -> HKEY_CURRENT_USER/Software/Blizzard Entertainment/Warcraft III/ InstallPath and HKEY_CURRENT_USER/Software/Eurobattle.net wc3dir should have the same value (of your current warcraft 3 path) (case-sensitive)

13) Low fps -> Make sure your drivers are up to date, if you have an old PC try this: http://dota.eurobattle.net/la/forum/index.php?topic=179302.0

14) "Unable to validate game version" -> See that the path to Documents/Warcraft 3 contains only english characters (http://eurobattle.net/threads/206091-1-28-2-known-problems-and-solutions?p=1649377&viewfull=1#post1649377)

15) Fixed Ratio Box is missing -> Check here

Topic about issues on eurobattle.net : http://eurobattle.net/threads/206091-1-28-2-known-problems-and-solutions?p=1648827#post1648827

Updated 19.06.2017
« Last Edit: July 17, 2017, 14:27 by kja12 »

Offline luke

  • ~evil~
  • Honored member
  • MonsterKill Member
  • *
  • Topic Author
  • Posts: 3430
  • Country: de
  • Karma: +449/-212
  • Awards Lagabuse Legend Hacks staff member [RARE] Shadow Raze Tour Award [RARE] Best B&U mod of the month 3 times in a row [EPIC] 3rd Place Admins Cup [EPIC] Uther Party Tournament Winner [COMMON]
    • View Profile
    • Awards
Re: New Patch [1.28.2]
« Reply #1 on: May 24, 2017, 21:38 »
How to fix resolution:

Many people seem to have a problem with their ingame resolution (wide stripes at the sides). The solution is really simple

1) Go to Warcraft 3's main menu
2) -> Settings
3) -> Video
4) Uncheck the fixed ratio box
5) Select your desktop resolution (now it should be listed in the listbox)
6) -> Apply
7) -> OK

If the "Fixed Aspect Ratio" Box isn't present in the video settings, set the "fixedaspect" value in the registry to 0 manually

« Last Edit: June 29, 2017, 21:14 by kja12 »