Author Topic: Uncap fps  (Read 489 times)

Offline iErnesto94

  • Global Admin
  • MonsterKill Member
  • *
  • Topic Author
  • Posts: 4332
  • Country: gr
  • Karma: +401/-353
  • Server Account: iErnesto94
    PSR: Loading
    Games: Loading
    Wins/Loses: Loading/Loading
    Hero K/D/A: Loading
    Creep K/D/N: Loading
    Show/hide more stats
  • Awards LA High Staff [EPIC] Patreon Supporter [RARE] DotA 5v5 Tournament Winner [EPIC] Winner of 1 Photoshop Challenge Contest [COMMON] 1v1 Windrunner Tour Winner [RARE] B&U staff member [RARE] Tours staff member [RARE] GFX staff member [RARE] 3v3 SHOM Tournament Winner [RARE] 3rd Place Admins Cup [EPIC] Best Couple (2v2) Tour Winner [RARE] LA Ladder #4-10 [LEGENDARY] IHRL Member [RARE]
    • View Profile
    • Awards
Uncap fps
« on: January 20, 2020, 21:04 »
Hello,
My warcraft runs on Fullscreen Windowed mode and its capped on 64fps. How could I change the fps limit and the screen mode? ( I think those two are connected)
Thank you in advance

PS: The problem is that my mouse cursor has lag and feels slow and unresponsive.
« Last Edit: January 20, 2020, 21:16 by iErnesto94 »

Offline luke

  • ~evil~
  • Honored member
  • MonsterKill Member
  • *
  • Posts: 3501
  • Country: de
  • Karma: +458/-218
  • Awards Warlock Tour Winner [RARE] Pudge Wars Tournament Winner [RARE] Hacks staff member [RARE] Shadow Raze Tour Award [RARE] Best B&U mod of the month 3 times in a row [EPIC] 3rd Place Admins Cup [EPIC] Uther Party Tournament Winner [COMMON]
    • View Profile
    • Awards
Re: Uncap fps
« Reply #1 on: January 20, 2020, 22:10 »
I don't think you can go over 64 fps, its hardcoded.

Try to launch the game with opengl checkbox ticked (eurobattlenet client). It will change the renderer and possibly fix the input lag.

What do you mean by fullscreen windowed mode? If its borderless window, you could also try to run it in windowed mode (stretch it to fit the screen)

It might also help to switch the video card which is used for wc3
« Last Edit: January 20, 2020, 22:15 by luke »

Online cen

  • Eurobattle.net Admin
  • WickedSick Member
  • *
  • Posts: 1807
  • Country: si
  • Karma: +209/-46
  • Lok'tar Ogar
  • Awards Lagabuse Legend LA High Staff [EPIC] MadBalls Tournament Winner [RARE] MVP Member [LEGENDARY]
    • View Profile
    • EuroBattle.net
    • Awards
Re: Uncap fps
« Reply #2 on: January 20, 2020, 22:20 »
I couldn't really find anything too useful but this guy claims native fullscreen uncaps it: https://us.forums.blizzard.com/en/warcraft3/t/wc3-60fps-cap-question/1948/6 the only problem being that this parameter was only added to w3 1.28 and we already set it with the client there.

Just for the sake of experiment, try out 1.28 with nativefullscreen ticked off and see if you get higher fps than 64 in some random map.

As luke said, maybe opengl will help, it's completely different rendering engine down below so could feel different, try it.

Other than that I found nothing. 64fps should not feel that bad, certainly not mouse lags.
« Last Edit: January 20, 2020, 22:22 by cen »

Offline Deynro

  • V.I.P
  • Pro Member
  • *
  • Posts: 351
  • Country: ro
  • Karma: +84/-107
  • Server Account: -Deynro-
    PSR: Loading
    Games: Loading
    Wins/Loses: Loading/Loading
    Hero K/D/A: Loading
    Creep K/D/N: Loading
    Show/hide more stats
  • Awards Contributor [COMMON] Winner of 5 Mirana Wars Tours [LEGENDARY] DotA 5v5 Tournament Winner [EPIC] Archer Wars Tournament Winner [RARE] Winner of 5 Pudge Wars Tours [LEGENDARY] Tour Pro Member [EPIC] 2v2 SHOM Tournament Winner [RARE] 5v5 Xmas Tournament Winner [EPIC] Invoker 1v1 Tournament Winner [RARE] Shadow Raze Tour Award [RARE] The Predator Tour Winner [RARE] MadBalls Tournament Winner [RARE] Tiny Tournament Winner [RARE] Warlock Tour Winner [RARE] 1v1 Earthshaker Tournament Winner [RARE] Winner of 5 Daily Tours [COMMON] 1v1 Windrunner Tour Winner [RARE] Uther Party Tournament Winner [COMMON] Admiral Tournament Winner [RARE] Leshrac 1v1 Tournament Winner [RARE]
    • View Profile
    • Awards
Re: Uncap fps
« Reply #3 on: January 21, 2020, 07:47 »
Try this:
http://dota.eurobattle.net/la/forum/index.php?topic=186135.msg676056#msg676056

Also, look for ,,Maxfps" in the dota.config file (you find it in the wc3 folder or in the eurobattle client at ,,Warcraft" ,,DotA Options" ,,Edit DotA config") and change it to ,,0"
It should look like:
MaxFPS=0

You have a SS in attachment with my FPS
« Last Edit: January 21, 2020, 12:26 by Deynro »
https://www.twitch.tv/deynro

Don't give up on your dreams, keep sleeping.


Offline iErnesto94

  • Global Admin
  • MonsterKill Member
  • *
  • Topic Author
  • Posts: 4332
  • Country: gr
  • Karma: +401/-353
  • Server Account: iErnesto94
    PSR: Loading
    Games: Loading
    Wins/Loses: Loading/Loading
    Hero K/D/A: Loading
    Creep K/D/N: Loading
    Show/hide more stats
  • Awards LA High Staff [EPIC] Patreon Supporter [RARE] DotA 5v5 Tournament Winner [EPIC] Winner of 1 Photoshop Challenge Contest [COMMON] 1v1 Windrunner Tour Winner [RARE] B&U staff member [RARE] Tours staff member [RARE] GFX staff member [RARE] 3v3 SHOM Tournament Winner [RARE] 3rd Place Admins Cup [EPIC] Best Couple (2v2) Tour Winner [RARE] LA Ladder #4-10 [LEGENDARY] IHRL Member [RARE]
    • View Profile
    • Awards
Re: Uncap fps
« Reply #4 on: January 21, 2020, 21:09 »
Thank you everyone for your response.

I enabled opengl and the mouse is more responsive and moves more smoothly.
It still feels a bit slow and less responsive than my other games but I think this happens because it runs on 60fps and not on 144 that im used to.

I tried what you said @Deynro but unfortunately my game still runs on 64 fps.
What I did:
- Lockfb -> change the value to 0
- dota.config changed  maxfps=0
- tried both with opengl on and off
It doesnt have to do with my gpu since i have rtx 2080ti.

Offline Deynro

  • V.I.P
  • Pro Member
  • *
  • Posts: 351
  • Country: ro
  • Karma: +84/-107
  • Server Account: -Deynro-
    PSR: Loading
    Games: Loading
    Wins/Loses: Loading/Loading
    Hero K/D/A: Loading
    Creep K/D/N: Loading
    Show/hide more stats
  • Awards Contributor [COMMON] Winner of 5 Mirana Wars Tours [LEGENDARY] DotA 5v5 Tournament Winner [EPIC] Archer Wars Tournament Winner [RARE] Winner of 5 Pudge Wars Tours [LEGENDARY] Tour Pro Member [EPIC] 2v2 SHOM Tournament Winner [RARE] 5v5 Xmas Tournament Winner [EPIC] Invoker 1v1 Tournament Winner [RARE] Shadow Raze Tour Award [RARE] The Predator Tour Winner [RARE] MadBalls Tournament Winner [RARE] Tiny Tournament Winner [RARE] Warlock Tour Winner [RARE] 1v1 Earthshaker Tournament Winner [RARE] Winner of 5 Daily Tours [COMMON] 1v1 Windrunner Tour Winner [RARE] Uther Party Tournament Winner [COMMON] Admiral Tournament Winner [RARE] Leshrac 1v1 Tournament Winner [RARE]
    • View Profile
    • Awards
Re: Uncap fps
« Reply #5 on: January 21, 2020, 22:45 »
Thank you everyone for your response.

I enabled opengl and the mouse is more responsive and moves more smoothly.
It still feels a bit slow and less responsive than my other games but I think this happens because it runs on 60fps and not on 144 that im used to.

I tried what you said @Deynro but unfortunately my game still runs on 64 fps.
What I did:
- Lockfb -> change the value to 0
- dota.config changed  maxfps=0
- tried both with opengl on and off
It doesnt have to do with my gpu since i have rtx 2080ti.

@iErnesto94
After changes in regedit you need to rr PC to take effect, also those changes works only on directx, so if you are using opengl, it's pointless
There can be 1 more thing, you may play on the integrated graphics instead dedicated
Do you have laptop or desktop?
You can try to play a game with this:
https://github.com/jobeid/TrayPwrD3

This is a simple executable that force the dedicated graphics to be used in all programs
https://www.twitch.tv/deynro

Don't give up on your dreams, keep sleeping.


Offline Practice

  • Newbie Member
  • *
  • Posts: 9
  • Karma: +0/-1
  • Server Account: Practice
    PSR: Loading
    Games: Loading
    Wins/Loses: Loading/Loading
    Hero K/D/A: Loading
    Creep K/D/N: Loading
    Show/hide more stats
    • View Profile
    • Awards
Re: Uncap fps
« Reply #6 on: January 23, 2020, 08:56 »
http://d1stats.ru/wc3fps/?lang=ru
possible guid, replace "ru" with "en"

Offline AntlermanXXL

  • Deer
  • Contributor
  • Hero Member
  • *
  • Posts: 568
  • Country: ru
  • Karma: +125/-260
  • Server Account: deer-door
    PSR: Loading
    Games: Loading
    Wins/Loses: Loading/Loading
    Hero K/D/A: Loading
    Creep K/D/N: Loading
    Show/hide more stats
  • Awards Advisor Deer Member Contributor [COMMON] Lagabuse Legend
    • View Profile
    • Awards
Re: Uncap fps
« Reply #7 on: January 23, 2020, 15:13 »
Or just put directx 8's library file to your folder, obvious
Twitch streams
http://www.youtube.com/user/AloneMonaX

Spoiler for Hiden:
10, 3rd places are mine, wew!

40:14 don_Kondo [Allies] olen olen
40:15 don_Kondo [Allies] olenishka
40:18 Hiatus [Allies] AHAH
40:21 don_Kondo [Allies] ya net olen
40:22 Hiatus [Allies] OLENISHKA
40:23 Hiatus [Allies] AHAHAH
40:25 don_Kondo [Allies] ya mala myshka
40:28 Hiatus [Allies] AHAHAHAH

Offline luke

  • ~evil~
  • Honored member
  • MonsterKill Member
  • *
  • Posts: 3501
  • Country: de
  • Karma: +458/-218
  • Awards Warlock Tour Winner [RARE] Pudge Wars Tournament Winner [RARE] Hacks staff member [RARE] Shadow Raze Tour Award [RARE] Best B&U mod of the month 3 times in a row [EPIC] 3rd Place Admins Cup [EPIC] Uther Party Tournament Winner [COMMON]
    • View Profile
    • Awards
Re: Uncap fps
« Reply #8 on: January 23, 2020, 18:51 »
Like deer said, move d3d8.dll from your rgc folder to eurobattle wc3 folder, can help