Author Topic: New Patch [1.28.5] (Custom Games)  (Read 1413 times)

Offline luke

  • ~evil~
  • Honored member
  • MonsterKill Member
  • *
  • Topic Author
  • Posts: 4347
  • Country: de
  • Karma: +412/-186
  • Awards Hacks staff member Shadow Raze Tour Award B&U staff member Best B&U mod of the month 3 times in a row 3rd Place Admins Cup Uther Party Tournament Winner
    • View Profile
    • Awards
New Patch [1.28.5] (Custom Games)
« on: August 18, 2017, 04:17 pm »
The server was updated to 1.28.5.

What was improved/fixed:


- Users with non-english usernames should be able to connect properly now
- Better 4K screen support
- Quick update from 1.28.x to 1.28.5 should work for everyone with unmodified english warcraft 3
- Full update from any version of any language to 1.28.5 is now possible by clicking the "Perform full W3 update" button in the Client (Note that your game will be in english afterwards)
- The Client will download the current DotA map if missing automatically
- Added DotA 6.88 gateway which is currently disabled
- Minor bug fixes in the Client

How to update:
- Simply launch the client and let it set up everything for you. If the quick update is possible, the Client will perform it (~50 MB), in any other case it will download the full update (~900 MB). A few popups will appear during the patching asking you to confirm the download.

The installer can be found here: http://warden.eurobattle.net/downloads/file/44
If you are a new user, you might need to install Visual C++ Redistributable 2015 x86 too.

Detailed guide: http://wiki.eurobattle.net/index.php?title=Main_Page

Common problems:

- Ingame resolution -> http://dota.eurobattle.net/la/forum/index.php?topic=179261.msg638722#msg638722
- Win XP users might not be able to connect with the "Unable to validate game version" message.
- "Unable to validate game version" for anyone else althrough the game is on 1.28.5 -> Check if the path to warcraft 3 contains non-english characters and change it if necessary.
- "Could not initialize wc3" at startup ->Perform the full update, if it won't help, download and extract 1.28.5.zip in your game folder.
- Unable to connect when using gproxy gateway -> Check for non-english characters in game's path and your firewall settings. If it won't help enable debugging and provide gproxy.log
- Game does not start -> Check if w3l.exe is present in your game folder, reinstall Client if not and add it to exceptions in your antivirus (if you have one)
- Missing w3k, w3l.exe files / asking for keys on startup -> reinstall the Client
- Green icons -> delete war3mod.mpq from your game folder and reinstall the Client

- Account activation -> Post your nick in this thread and your account will be activated manually.

-Fewer games -> wait until bot owners will set their bots up for this patch

More details in our Wiki

If you have any questions or a problem not mentioned here, feel free to create a topic about it or contact us on Discord
« Last Edit: October 06, 2018, 06:57 pm by kja12 »